What’s Vulnerable › Vulnerabilities
CVE-2024-26540
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-based buffer overflow in Clmg before 3.3.3 can occur via a crafted file to cimg_library::CImg<unsigned char>::_load_analyze.
Affected products
- Cimg: before 3.3.3 — fixed in 3.3.3
How to fix
Upgrade to a fixed version: Cimg 3.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-26540 or the next vulnerability affects your stack