What’s Vulnerable › Vulnerabilities
CVE-2024-26579: Apache Inlong JDBC Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-08 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.7.0 through 1.11.0, the attackers can bypass using malicious parameters. Users are advised to upgrade to Apache InLong's 1.12.0 or cherry-pick [1], [2] to solve it. [1] https://github.com/apache/inlong/pull/9694 [2] https://github.com/apache/inlong/pull/9707
Affected products
- Apache Software Foundation Apache InLong: from 1.7.0 before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.12.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/05/09/2
- https://github.com/advisories/GHSA-fgh3-pwmp-3qw3
- https://lists.apache.org/thread/d2hndtvh6bll4pkl91o2oqxyynhr54k3
- http://www.openwall.com/lists/oss-security/2024/05/09/2
- https://github.com/advisories/GHSA-fgh3-pwmp-3qw3
- https://lists.apache.org/thread/d2hndtvh6bll4pkl91o2oqxyynhr54k3
Get alerted when CVE-2024-26579 or the next vulnerability affects your stack