What’s Vulnerable › Vulnerabilities
CVE-2024-2658: Local privilege escalation in FlexNet Publisher
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-427
Description
A misconfiguration in lmadmin.exe of FlexNet Publisher versions prior to 2024 R1 (11.19.6.0) allows the OpenSSL configuration file to load from a non-existent directory. An unauthorized, locally authenticated user with low privileges can potentially create the directory and load a specially crafted openssl.conf file leading to the execution of a malicious DLL (Dynamic-Link Library) with elevated privileges.
Affected products
- Flexera FlexNet Publisher: before 2024 R1 (11.19.6.0) — fixed in 2024 R1 (11.19.6.0)
How to fix
Upgrade to a fixed version: Flexera FlexNet Publisher 2024 R1 (11.19.6.0). Check the vendor advisory for mitigations.
References
- https://community.flexera.com/s/article/cve-2024-2658-flexnet-publisher-potential-local-privilege-escalation-issue
- https://www.zerodayinitiative.com/advisories/ZDI-24-359/
Get alerted when CVE-2024-2658 or the next vulnerability affects your stack