What’s Vulnerable › Vulnerabilities

CVE-2024-26580: Apache InLong: Logged-in user could exploit an arbitrary file read vulnerability

Description

Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.11.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-26580 or the next vulnerability affects your stack