What’s Vulnerable › Vulnerabilities
CVE-2024-26599: pwm: Fix out-of-bounds access in of_pwm_single_xlate()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-23 · updated 2026-06-17
- Weakness: CWE-119
Description
In the Linux kernel, the following vulnerability has been resolved: pwm: Fix out-of-bounds access in of_pwm_single_xlate() With args->args_count == 2 args->args[2] is not defined. Actually the flags are contained in args->args[1].
Affected products
- Linux kernel: from 5.17 before 6.1.75; from 6.2.0 before 6.6.14; from 6.7.0 before 6.7.2 — fixed in 6.1.75, 6.6.14, 6.7.2
How to fix
Upgrade to a fixed version: Linux kernel 6.1.75, 6.6.14, 6.7.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7b85554c7c2aee91171e038e4d5442ffa130b282
- https://git.kernel.org/stable/c/a297d07b9a1e4fb8cda25a4a2363a507d294b7c9
- https://git.kernel.org/stable/c/bae45b7ebb31984b63b13c3519fd724b3ce92123
- https://git.kernel.org/stable/c/e5f2b4b62977fb6c2efcbc5779e0c9dce18215f7
- https://git.kernel.org/stable/c/7b85554c7c2aee91171e038e4d5442ffa130b282
- https://git.kernel.org/stable/c/a297d07b9a1e4fb8cda25a4a2363a507d294b7c9
- https://git.kernel.org/stable/c/bae45b7ebb31984b63b13c3519fd724b3ce92123
- https://git.kernel.org/stable/c/e5f2b4b62977fb6c2efcbc5779e0c9dce18215f7
Get alerted when CVE-2024-26599 or the next vulnerability affects your stack