What’s Vulnerable › Vulnerabilities

CVE-2024-2660: Vault TLS Cert Auth Method Did Not Correctly Validate OCSP Responses

Description

Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Vault 1.14.11, 1.15.7, 1.16.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-2660 or the next vulnerability affects your stack