What’s Vulnerable › Vulnerabilities
CVE-2024-26753: crypto: virtio/akcipher - Fix stack overflow on memcpy
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: virtio/akcipher - Fix stack overflow on memcpy sizeof(struct virtio_crypto_akcipher_session_para) is less than sizeof(struct virtio_crypto_op_ctrl_req::u), copying more bytes from stack variable leads stack overflow. Clang reports this issue by commands: make -j CC=clang-14 mrproper >/dev/null 2>&1 make -j O=/tmp/crypto-build CC=clang-14 allmodconfig >/dev/null 2>&1 make -j O=/tmp/crypto-build W=1 CC=clang-14 drivers/crypto/virtio/ virtio_crypto_akcipher_algs.o
Affected products
- Debian Linux: 10.0
- Linux kernel: from 5.10.209 before 5.10.212; from 5.18 before 6.1.80; from 6.2 before 6.6.19; from 6.7 before 6.7.7; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4, 6.8-rc5 — fixed in 5.10.212, 6.1.80, 6.6.19, 6.7.7
How to fix
Upgrade to a fixed version: Linux kernel 5.10.212, 6.1.80, 6.6.19, 6.7.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/37077ed16c7793e21b005979d33f8a61565b7e86
- https://git.kernel.org/stable/c/62f361bfea60c6afc3df09c1ad4152e6507f6f47
- https://git.kernel.org/stable/c/b0365460e945e1117b47cf7329d86de752daff63
- https://git.kernel.org/stable/c/c0ec2a712daf133d9996a8a1b7ee2d4996080363
- https://git.kernel.org/stable/c/ef1e47d50324e232d2da484fe55a54274eeb9bc1
- https://git.kernel.org/stable/c/37077ed16c7793e21b005979d33f8a61565b7e86
- https://git.kernel.org/stable/c/62f361bfea60c6afc3df09c1ad4152e6507f6f47
- https://git.kernel.org/stable/c/b0365460e945e1117b47cf7329d86de752daff63
- https://git.kernel.org/stable/c/c0ec2a712daf133d9996a8a1b7ee2d4996080363
- https://git.kernel.org/stable/c/ef1e47d50324e232d2da484fe55a54274eeb9bc1
- https://lists.debian.org/debian-lts-announce/2024/06/msg00017.html
Get alerted when CVE-2024-26753 or the next vulnerability affects your stack