What’s Vulnerable › Vulnerabilities
CVE-2024-26795: riscv: Sparse-Memory/vmemmap out-of-bounds fix
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: riscv: Sparse-Memory/vmemmap out-of-bounds fix Offset vmemmap so that the first page of vmemmap will be mapped to the first page of physical memory in order to ensure that vmemmap’s bounds will be respected during pfn_to_page()/page_to_pfn() operations. The conversion macros will produce correct SV39/48/57 addresses for every possible/valid DRAM_BASE inside the physical memory limits. v2:Address Alex's comments
Affected products
- Debian Linux: 10.0
- Linux kernel: from 5.4 before 5.10.212; from 5.11 before 5.15.151; from 5.16 before 6.1.81; from 6.2 before 6.6.21; from 6.7 before 6.7.9; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4, 6.8-rc5, 6.8-rc6 — fixed in 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.212, 5.15.151, 6.1.81, 6.6.21. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2a1728c15ec4f45ed9248ae22f626541c179bfbe
- https://git.kernel.org/stable/c/5941a90c55d3bfba732b32208d58d997600b44ef
- https://git.kernel.org/stable/c/8310080799b40fd9f2a8b808c657269678c149af
- https://git.kernel.org/stable/c/a11dd49dcb9376776193e15641f84fcc1e5980c9
- https://git.kernel.org/stable/c/a278d5c60f21aa15d540abb2f2da6e6d795c3e6e
- https://git.kernel.org/stable/c/2a1728c15ec4f45ed9248ae22f626541c179bfbe
- https://git.kernel.org/stable/c/5941a90c55d3bfba732b32208d58d997600b44ef
- https://git.kernel.org/stable/c/8310080799b40fd9f2a8b808c657269678c149af
- https://git.kernel.org/stable/c/8af1c121b0102041809bc137ec600d1865eaeedd
- https://git.kernel.org/stable/c/a11dd49dcb9376776193e15641f84fcc1e5980c9
- https://git.kernel.org/stable/c/a278d5c60f21aa15d540abb2f2da6e6d795c3e6e
- https://lists.debian.org/debian-lts-announce/2024/06/msg00017.html
Get alerted when CVE-2024-26795 or the next vulnerability affects your stack