What’s Vulnerable › Vulnerabilities
CVE-2024-26797: drm/amd/display: Prevent potential buffer overflow in map_hw_resources
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Prevent potential buffer overflow in map_hw_resources Adds a check in the map_hw_resources function to prevent a potential buffer overflow. The function was accessing arrays using an index that could potentially be greater than the size of the arrays, leading to a buffer overflow. Adds a check to ensure that the index is within the bounds of the arrays. If the index is out of bounds, an error message is printed and break it will continue execution with just ignoring extra data early to prevent the buffer overflow. Reported by smatch: drivers/gpu/drm/amd/amdgpu/../display/dc/dml2/dml2_wrapper.c:79 map_hw_resources() error: buffer overflow 'dml2->v20.scratch.dml_to_dc_pipe_mapping.disp_cfg_to_stream_id' 6 <= 7 drivers/gpu/drm/amd/amdgpu/../display/dc/dml2/dml2_wrapper.c:81 map_hw_resources() error: buffer overflow 'dml2->v20.scratch.dml_to_dc_pipe_mapping.disp_cfg_to_plane_id' 6 <= 7
Affected products
- Linux kernel: from 6.7 before 6.7.9; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4, 6.8-rc5, 6.8-rc6 — fixed in 6.7.9
How to fix
Upgrade to a fixed version: Linux kernel 6.7.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f8ca019544a252d1afb468ce840c6dcbac73af4
- https://git.kernel.org/stable/c/50a6302cf881f67f1410461a68fe9eabd00ff31d
- https://git.kernel.org/stable/c/0f8ca019544a252d1afb468ce840c6dcbac73af4
- https://git.kernel.org/stable/c/50a6302cf881f67f1410461a68fe9eabd00ff31d
Get alerted when CVE-2024-26797 or the next vulnerability affects your stack