What’s Vulnerable › Vulnerabilities
CVE-2024-26814: vfio/fsl-mc: Block calling interrupt handler without trigger
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-05 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: vfio/fsl-mc: Block calling interrupt handler without trigger The eventfd_ctx trigger pointer of the vfio_fsl_mc_irq object is initially NULL and may become NULL if the user sets the trigger eventfd to -1. The interrupt handler itself is guaranteed that trigger is always valid between request_irq() and free_irq(), but the loopback testing mechanisms to invoke the handler function need to test the trigger. The triggering and setting ioctl paths both make use of igate and are therefore mutually exclusive. The vfio-fsl-mc driver does not make use of irqfds, nor does it support any sort of masking operations, therefore unlike vfio-pci and vfio-platform, the flow can remain essentially unchanged.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 5.10 before 6.1.84; from 6.2 before 6.6.24; from 6.7 before 6.7.12; from 6.8 before 6.8.3; from 6.8.4 through 6.8.12 — fixed in 6.1.84, 6.6.24, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.84, 6.6.24, 6.7.12, 6.8.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/083e750c9f5f4c3bf61161330fb84d7c8e8bb417
- https://git.kernel.org/stable/c/250219c6a556f8c69c5910fca05a59037e24147d
- https://git.kernel.org/stable/c/6ec0d88166dac43f29e96801c0927d514f17add9
- https://git.kernel.org/stable/c/7447d911af699a15f8d050dfcb7c680a86f87012
- https://git.kernel.org/stable/c/a563fc18583ca4f42e2fdd0c70c7c618288e7ede
- https://git.kernel.org/stable/c/de87511fb0404d23b6da5f4660383b6ed095e28d
- https://git.kernel.org/stable/c/ee0bd4ad780dfbb60355b99f25063357ab488267
- https://git.kernel.org/stable/c/083e750c9f5f4c3bf61161330fb84d7c8e8bb417
- https://git.kernel.org/stable/c/250219c6a556f8c69c5910fca05a59037e24147d
- https://git.kernel.org/stable/c/6ec0d88166dac43f29e96801c0927d514f17add9
- https://git.kernel.org/stable/c/7447d911af699a15f8d050dfcb7c680a86f87012
- https://git.kernel.org/stable/c/a563fc18583ca4f42e2fdd0c70c7c618288e7ede
Get alerted when CVE-2024-26814 or the next vulnerability affects your stack