What’s Vulnerable › Vulnerabilities
CVE-2024-26822: smb: client: set correct id, uid and cruid for multiuser automounts
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: smb: client: set correct id, uid and cruid for multiuser automounts When uid, gid and cruid are not specified, we need to dynamically set them into the filesystem context used for automounting otherwise they'll end up reusing the values from the parent mount.
Affected products
- Linux kernel: from 6.2 before 6.6.18; from 6.7 before 6.7.6; 5.15.124, 6.1.54, 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4 — fixed in 6.6.18, 6.7.6
How to fix
Upgrade to a fixed version: Linux kernel 6.6.18, 6.7.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2ceba8ae1bd1f5589548cb722a5c583ca3a2dede
- https://git.kernel.org/stable/c/4508ec17357094e2075f334948393ddedbb75157
- https://git.kernel.org/stable/c/4a6e4c56721a3e6e2550b72ec56aab306c4607a7
- https://git.kernel.org/stable/c/7590ba9057c6d74c66f3b909a383ec47cd2f27fb
- https://git.kernel.org/stable/c/c2aa2718cda2d56b4a551cb40043e9abc9684626
- https://git.kernel.org/stable/c/4508ec17357094e2075f334948393ddedbb75157
- https://git.kernel.org/stable/c/7590ba9057c6d74c66f3b909a383ec47cd2f27fb
- https://git.kernel.org/stable/c/c2aa2718cda2d56b4a551cb40043e9abc9684626
Get alerted when CVE-2024-26822 or the next vulnerability affects your stack