What’s Vulnerable › Vulnerabilities
CVE-2024-26828: cifs: fix underflow in parse_server_interfaces()
- Severity: critical (CVSS 9.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-10-30
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: cifs: fix underflow in parse_server_interfaces() In this loop, we step through the buffer and after each item we check if the size_left is greater than the minimum size we need. However, the problem is that "bytes_left" is type ssize_t while sizeof() is type size_t. That means that because of type promotion, the comparison is done as an unsigned and if we have negative bytes left the loop continues instead of ending.
Affected products
- Linux kernel: from 4.18 before 6.1.79; from 6.2 before 6.6.18; from 6.7 before 6.7.6; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4 — fixed in 6.1.79, 6.6.18, 6.7.6
- Linux: 4.18 — fixed in 6.8
How to fix
Upgrade to a fixed version: Linux kernel 6.1.79, 6.6.18, 6.7.6; Linux 6.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3babdcb5f1809a9a41e31547a063dedf6bb44cca
- https://git.kernel.org/stable/c/7190353835b4a219abb70f90b06cdcae97f11512
- https://git.kernel.org/stable/c/cffe487026be13eaf37ea28b783d9638ab147204
- https://git.kernel.org/stable/c/df2af9fdbc4ddde18a3371c4ca1a86596e8be301
- https://git.kernel.org/stable/c/f7ff1c89fb6e9610d2b01c1821727729e6609308
- https://git.kernel.org/stable/c/7190353835b4a219abb70f90b06cdcae97f11512
- https://git.kernel.org/stable/c/cffe487026be13eaf37ea28b783d9638ab147204
- https://git.kernel.org/stable/c/df2af9fdbc4ddde18a3371c4ca1a86596e8be301
- https://git.kernel.org/stable/c/f7ff1c89fb6e9610d2b01c1821727729e6609308
Get alerted when CVE-2024-26828 or the next vulnerability affects your stack