What’s Vulnerable › Vulnerabilities
CVE-2024-26836: platform/x86: think-lmi: Fix password opcode ordering for workstations
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: think-lmi: Fix password opcode ordering for workstations The Lenovo workstations require the password opcode to be run before the attribute value is changed (if Admin password is enabled). Tested on some Thinkpads to confirm they are OK with this order too.
Affected products
- Linux kernel: from 5.17 before 6.6.55; from 6.7 before 6.7.7; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4, 6.8-rc5 — fixed in 6.6.55, 6.7.7
How to fix
Upgrade to a fixed version: Linux kernel 6.6.55, 6.7.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2bfbe1e0aed00ba51d58573c79452fada3f62ed4
- https://git.kernel.org/stable/c/2deb10a99671afda30f834e95e5b992a805bba6a
- https://git.kernel.org/stable/c/6f7d0f5fd8e440c3446560100ac4ff9a55eec340
- https://git.kernel.org/stable/c/2bfbe1e0aed00ba51d58573c79452fada3f62ed4
- https://git.kernel.org/stable/c/6f7d0f5fd8e440c3446560100ac4ff9a55eec340
Get alerted when CVE-2024-26836 or the next vulnerability affects your stack