What’s Vulnerable › Vulnerabilities
CVE-2024-26930: scsi: qla2xxx: Fix double free of the ha->vp_map pointer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qla2xxx: Fix double free of the ha->vp_map pointer Coverity scan reported potential risk of double free of the pointer ha->vp_map. ha->vp_map was freed in qla2x00_mem_alloc(), and again freed in function qla2x00_mem_free(ha). Assign NULL to vp_map and kfree take care of NULL.
Affected products
- Linux kernel: from 6.3 before 6.6.24; from 6.7 before 6.7.12; from 6.8 before 6.8.3; 6.9-rc1 — fixed in 6.6.24, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 6.6.24, 6.7.12, 6.8.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/825d63164a2e6bacb059a9afb5605425b485413f
- https://git.kernel.org/stable/c/b7deb675d674f44e0ddbab87fee8f9f098925e73
- https://git.kernel.org/stable/c/e288285d47784fdcf7c81be56df7d65c6f10c58b
- https://git.kernel.org/stable/c/f14cee7a882cb79528f17a2335f53e9fd1848467
- https://git.kernel.org/stable/c/825d63164a2e6bacb059a9afb5605425b485413f
- https://git.kernel.org/stable/c/b7deb675d674f44e0ddbab87fee8f9f098925e73
- https://git.kernel.org/stable/c/e288285d47784fdcf7c81be56df7d65c6f10c58b
- https://git.kernel.org/stable/c/f14cee7a882cb79528f17a2335f53e9fd1848467
Get alerted when CVE-2024-26930 or the next vulnerability affects your stack