What’s Vulnerable › Vulnerabilities
CVE-2024-26936: ksmbd: validate request buffer size in smb2_allocate_rsp_buf()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: validate request buffer size in smb2_allocate_rsp_buf() The response buffer should be allocated in smb2_allocate_rsp_buf before validating request. But the fields in payload as well as smb2 header is used in smb2_allocate_rsp_buf(). This patch add simple buffer size validation to avoid potencial out-of-bounds in request buffer.
Affected products
- Linux kernel: from 5.15 before 5.15.159; from 5.16 before 6.1.88; from 6.2 before 6.6.29; from 6.7 before 6.8.8; 6.9-rc1, 6.9-rc2, 6.9-rc3, 6.9-rc4, 6.9-rc5 — fixed in 5.15.159, 6.1.88, 6.6.29, 6.8.8
How to fix
Upgrade to a fixed version: Linux kernel 5.15.159, 6.1.88, 6.6.29, 6.8.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/17cf0c2794bdb6f39671265aa18aea5c22ee8c4a
- https://git.kernel.org/stable/c/21ff9d7d223c5c19cb4334009e4c0c83a2f4d674
- https://git.kernel.org/stable/c/2c27a64a2bc47d9bfc7c3cf8be14be53b1ee7cb6
- https://git.kernel.org/stable/c/5c20b242d4fed73a93591e48bfd9772e2322fb11
- https://git.kernel.org/stable/c/8f3d0bf1d0c62b539d54c5b9108a845cff619b99
- https://git.kernel.org/stable/c/17cf0c2794bdb6f39671265aa18aea5c22ee8c4a
- https://git.kernel.org/stable/c/21ff9d7d223c5c19cb4334009e4c0c83a2f4d674
- https://git.kernel.org/stable/c/2c27a64a2bc47d9bfc7c3cf8be14be53b1ee7cb6
- https://git.kernel.org/stable/c/5c20b242d4fed73a93591e48bfd9772e2322fb11
- https://git.kernel.org/stable/c/8f3d0bf1d0c62b539d54c5b9108a845cff619b99
Get alerted when CVE-2024-26936 or the next vulnerability affects your stack