What’s Vulnerable › Vulnerabilities
CVE-2024-26952: ksmbd: fix potencial out-of-bounds when buffer offset is invalid
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix potencial out-of-bounds when buffer offset is invalid I found potencial out-of-bounds when buffer offset fields of a few requests is invalid. This patch set the minimum value of buffer offset field to ->Buffer offset to validate buffer length.
Affected products
- Linux kernel: from 5.15 before 5.15.181; from 5.16 before 6.1.119; from 6.2 before 6.6.32; from 6.7 before 6.7.12; from 6.8 before 6.8.3 — fixed in 5.15.181, 6.1.119, 6.6.32, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.181, 6.1.119, 6.6.32, 6.7.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c5541b4c980626fa3cab16ba1a451757778bbb5
- https://git.kernel.org/stable/c/2dcda336b6e80b72d58d30d40f2fad9724e5fe63
- https://git.kernel.org/stable/c/39bdc4197acf2ed13269167ccf093ee28cfa2a4e
- https://git.kernel.org/stable/c/480469f145e5abf83361e608734e421b7d99693d
- https://git.kernel.org/stable/c/ad6480c9a5d884e2704adc51d69895d93339176c
- https://git.kernel.org/stable/c/c6cd2e8d2d9aa7ee35b1fa6a668e32a22a9753da
- https://git.kernel.org/stable/c/0c5541b4c980626fa3cab16ba1a451757778bbb5
- https://git.kernel.org/stable/c/2dcda336b6e80b72d58d30d40f2fad9724e5fe63
- https://git.kernel.org/stable/c/39bdc4197acf2ed13269167ccf093ee28cfa2a4e
- https://git.kernel.org/stable/c/c6cd2e8d2d9aa7ee35b1fa6a668e32a22a9753da
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-26952 or the next vulnerability affects your stack