What’s Vulnerable › Vulnerabilities
CVE-2024-26954: ksmbd: fix slab-out-of-bounds in smb_strndup_from_utf16()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix slab-out-of-bounds in smb_strndup_from_utf16() If ->NameOffset of smb2_create_req is smaller than Buffer offset of smb2_create_req, slab-out-of-bounds read can happen from smb2_open. This patch set the minimum value of the name offset to the buffer offset to validate name length of smb2_create_req().
Affected products
- Linux kernel: from 5.15 before 6.1.119; from 6.2 before 6.7.12; from 6.8 before 6.8.3 — fixed in 6.1.119, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.119, 6.7.12, 6.8.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3b8da67191e938a63d2736dabb4ac5d337e5de57
- https://git.kernel.org/stable/c/4f97e6a9d62cb1fce82fbf4baff44b83221bc178
- https://git.kernel.org/stable/c/9e4937cbc150f9d5a9b5576e1922ef0b5ed2eb72
- https://git.kernel.org/stable/c/a80a486d72e20bd12c335bcd38b6e6f19356b0aa
- https://git.kernel.org/stable/c/d70c2e0904ab3715c5673fd45788a464a246d1db
- https://git.kernel.org/stable/c/3b8da67191e938a63d2736dabb4ac5d337e5de57
- https://git.kernel.org/stable/c/4f97e6a9d62cb1fce82fbf4baff44b83221bc178
- https://git.kernel.org/stable/c/a80a486d72e20bd12c335bcd38b6e6f19356b0aa
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-26954 or the next vulnerability affects your stack