What’s Vulnerable › Vulnerabilities
CVE-2024-26964: usb: xhci: Add error handling in xhci_map_urb_for_dma
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: usb: xhci: Add error handling in xhci_map_urb_for_dma Currently xhci_map_urb_for_dma() creates a temporary buffer and copies the SG list to the new linear buffer. But if the kzalloc_node() fails, then the following sg_pcopy_to_buffer() can lead to crash since it tries to memcpy to NULL pointer. So return -ENOMEM if kzalloc returns null pointer.
Affected products
- Linux kernel: from 5.11 before 5.15.154; from 5.16 before 6.1.84; from 6.2 before 6.6.24; from 6.7 before 6.7.12; from 6.8 before 6.8.3 — fixed in 5.15.154, 6.1.84, 6.6.24, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.154, 6.1.84, 6.6.24, 6.7.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4a49d24fdec0a802aa686a567a3989a9fdf4e5dd
- https://git.kernel.org/stable/c/620b6cf2f1a270f48d38e6b8ce199c1acb3e90f4
- https://git.kernel.org/stable/c/7b6cc33593d7ccfc3011b290849cfa899db46757
- https://git.kernel.org/stable/c/962300a360d24c5be5a188cda48da58a37e4304d
- https://git.kernel.org/stable/c/b2c898469dfc388f619c6c972a28466cbb1442ea
- https://git.kernel.org/stable/c/be95cc6d71dfd0cba66e3621c65413321b398052
- https://git.kernel.org/stable/c/4a49d24fdec0a802aa686a567a3989a9fdf4e5dd
- https://git.kernel.org/stable/c/620b6cf2f1a270f48d38e6b8ce199c1acb3e90f4
- https://git.kernel.org/stable/c/7b6cc33593d7ccfc3011b290849cfa899db46757
- https://git.kernel.org/stable/c/962300a360d24c5be5a188cda48da58a37e4304d
- https://git.kernel.org/stable/c/b2c898469dfc388f619c6c972a28466cbb1442ea
- https://git.kernel.org/stable/c/be95cc6d71dfd0cba66e3621c65413321b398052
Get alerted when CVE-2024-26964 or the next vulnerability affects your stack