What’s Vulnerable › Vulnerabilities
CVE-2024-2697: Swift Framework < 2024.0.0 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The socialdriver-framework WordPress plugin before 2024.0.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- socialdriver-framework: before 2024.0.0 — fixed in 2024.0.0
How to fix
Upgrade to a fixed version: socialdriver-framework 2024.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c430b30d-61db-45f5-8499-91b491503b9c/
- https://wpscan.com/vulnerability/c430b30d-61db-45f5-8499-91b491503b9c/
- https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/socialdriver-framework/swift-framework-202400-authenticated-contributor-stored-cross-site-scripting-via-shortcode
Get alerted when CVE-2024-2697 or the next vulnerability affects your stack