What’s Vulnerable › Vulnerabilities
CVE-2024-27017: netfilter: nft_set_pipapo: walk over current view on netlink dump
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: nft_set_pipapo: walk over current view on netlink dump The generation mask can be updated while netlink dump is in progress. The pipapo set backend walk iterator cannot rely on it to infer what view of the datastructure is to be used. Add notation to specify if user wants to read/update the set. Based on patch from Florian Westphal.
Affected products
- Fedoraproject Fedora: 38, 39, 40
- Linux kernel: from 6.4 before 6.8.8; 6.9-rc1, 6.9-rc2, 6.9-rc3, 6.9-rc4 — fixed in 6.8.8
How to fix
Upgrade to a fixed version: Linux kernel 6.8.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/29b359cf6d95fd60730533f7f10464e95bd17c73
- https://git.kernel.org/stable/c/52735a010f37580b3a569a996f878fdd87425650
- https://git.kernel.org/stable/c/721715655c72640567e8742567520c99801148ed
- https://git.kernel.org/stable/c/ce9fef54c5ec9912a0c9a47bac3195cc41b14679
- https://git.kernel.org/stable/c/f24d8abc2bb8cbf31ec713336e402eafa8f42f60
- https://git.kernel.org/stable/c/ff89db14c63a827066446460e39226c0688ef786
- https://git.kernel.org/stable/c/29b359cf6d95fd60730533f7f10464e95bd17c73
- https://git.kernel.org/stable/c/721715655c72640567e8742567520c99801148ed
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4EZ6PJW7VOZ224TD7N4JZNU6KV32ZJ53/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DAMSOZXJEPUOXW33WZYWCVAY7Z5S7OOY/
Get alerted when CVE-2024-27017 or the next vulnerability affects your stack