What’s Vulnerable › Vulnerabilities
CVE-2024-27039: clk: hisilicon: hi3559a: Fix an erroneous devm_kfree()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: clk: hisilicon: hi3559a: Fix an erroneous devm_kfree() 'p_clk' is an array allocated just before the for loop for all clk that need to be registered. It is incremented at each loop iteration. If a clk_register() call fails, 'p_clk' may point to something different from what should be freed. The best we can do, is to avoid this wrong release of memory.
Affected products
- Linux kernel: from 5.14 before 5.15.153; from 5.16 before 6.1.83; from 6.2 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.153, 6.1.83, 6.6.23, 6.7.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2cc572e0085ebd4b662b74a0f43222bc00df9a00
- https://git.kernel.org/stable/c/3f8445f1c746fda180a7f75372ed06b24e9cefe2
- https://git.kernel.org/stable/c/64c6a38136b74a2f18c42199830975edd9fbc379
- https://git.kernel.org/stable/c/95d1f1228c1bb54803ae57525b76db60e99b37e4
- https://git.kernel.org/stable/c/d575765b1b62e8bdb00af11caa1aabeb01763d9f
- https://git.kernel.org/stable/c/e0b0d1c46a2ce1e46b79d004a7270fdef872e097
- https://git.kernel.org/stable/c/2cc572e0085ebd4b662b74a0f43222bc00df9a00
- https://git.kernel.org/stable/c/3f8445f1c746fda180a7f75372ed06b24e9cefe2
- https://git.kernel.org/stable/c/64c6a38136b74a2f18c42199830975edd9fbc379
- https://git.kernel.org/stable/c/95d1f1228c1bb54803ae57525b76db60e99b37e4
- https://git.kernel.org/stable/c/d575765b1b62e8bdb00af11caa1aabeb01763d9f
- https://git.kernel.org/stable/c/e0b0d1c46a2ce1e46b79d004a7270fdef872e097
Get alerted when CVE-2024-27039 or the next vulnerability affects your stack