What’s Vulnerable › Vulnerabilities
CVE-2024-27050: libbpf: Use OPTS_SET() macro in bpf_xdp_query()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: libbpf: Use OPTS_SET() macro in bpf_xdp_query() When the feature_flags and xdp_zc_max_segs fields were added to the libbpf bpf_xdp_query_opts, the code writing them did not use the OPTS_SET() macro. This causes libbpf to write to those fields unconditionally, which means that programs compiled against an older version of libbpf (with a smaller size of the bpf_xdp_query_opts struct) will have its stack corrupted by libbpf writing out of bounds. The patch adding the feature_flags field has an early bail out if the feature_flags field is not part of the opts struct (via the OPTS_HAS) macro, but the patch adding xdp_zc_max_segs does not. For consistency, this fix just changes the assignments to both fields to use the OPTS_SET() macro.
Affected products
- Linux kernel: from 6.6 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 6.6.23, 6.7.11, 6.8.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/682ddd62abd4bdcee7584246903e7a2df005fe0d
- https://git.kernel.org/stable/c/92a871ab9fa59a74d013bc04f321026a057618e7
- https://git.kernel.org/stable/c/cd3be9843247edb8fc6fcd8d8237cbce2bc19f5e
- https://git.kernel.org/stable/c/fa5bef5e80c6a3321b2b1a7070436f3bc5daf07c
- https://git.kernel.org/stable/c/682ddd62abd4bdcee7584246903e7a2df005fe0d
- https://git.kernel.org/stable/c/92a871ab9fa59a74d013bc04f321026a057618e7
- https://git.kernel.org/stable/c/cd3be9843247edb8fc6fcd8d8237cbce2bc19f5e
- https://git.kernel.org/stable/c/fa5bef5e80c6a3321b2b1a7070436f3bc5daf07c
Get alerted when CVE-2024-27050 or the next vulnerability affects your stack