What’s Vulnerable › Vulnerabilities
CVE-2024-27085: Denial of service through invites in Discourse
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. In affected versions users that are allowed to invite others can inject arbitrarily large data in parameters used in the invite route. The problem has been patched in the latest version of Discourse. Users are advised to upgrade. Users unable to upgrade should disable invites or restrict access to them using the `invite allowed groups` site setting.
Affected products
- discourse: before 3.2.0; before 3.3.0; 3.3.0-beta1 — fixed in 3.2.0, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.0, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/62ea382247c1f87361d186392c45ca74c83be295
- https://github.com/discourse/discourse/security/advisories/GHSA-cvp5-h7p8-mjj6
- https://github.com/discourse/discourse/commit/62ea382247c1f87361d186392c45ca74c83be295
- https://github.com/discourse/discourse/security/advisories/GHSA-cvp5-h7p8-mjj6
Get alerted when CVE-2024-27085 or the next vulnerability affects your stack