What’s Vulnerable › Vulnerabilities
CVE-2024-27090: Decidim vulnerable to data disclosure through the embed feature
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-200
Description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded (such as a Participatory Process, an Assembly, a Proposal, a Result, etc), then some data of this resource could be accessed. This vulnerability is fixed in 0.27.6.
Affected products
- decidim: before 0.27.6 — fixed in 0.27.6
How to fix
Upgrade to a fixed version: decidim 0.27.6. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/commit/1756fa639ef393ca8e8bb16221cab2e2e7875705
- https://github.com/decidim/decidim/pull/12528
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/security/advisories/GHSA-qcj6-vxwx-4rqv
- https://github.com/decidim/decidim/commit/1756fa639ef393ca8e8bb16221cab2e2e7875705
- https://github.com/decidim/decidim/pull/12528
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/security/advisories/GHSA-qcj6-vxwx-4rqv
Get alerted when CVE-2024-27090 or the next vulnerability affects your stack