What’s Vulnerable › Vulnerabilities
CVE-2024-27091: GeoNode stored XSS to full account takeover
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.
Affected products
- geonode: from 3.2.0 (excl.) before 4.2.3 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: geonode 4.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/GeoNode/geonode/commit/e53bdeff331f4b577918927d60477d4b50cca02f
- https://github.com/GeoNode/geonode/security/advisories/GHSA-rwcv-whm8-fmxm
- https://github.com/GeoNode/geonode/commit/e53bdeff331f4b577918927d60477d4b50cca02f
- https://github.com/GeoNode/geonode/security/advisories/GHSA-rwcv-whm8-fmxm
Get alerted when CVE-2024-27091 or the next vulnerability affects your stack