What’s Vulnerable › Vulnerabilities
CVE-2024-27095: Decidim cross-site scripting (XSS) in the admin panel
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
Affected products
- decidim: before 0.27.6; 0.28.0, 0.28.0-rc1, 0.28.0-rc2, 0.28.0-rc3, 0.28.0-rc4, 0.28.0-rc5 — fixed in 0.27.6
How to fix
Upgrade to a fixed version: decidim 0.27.6. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/releases/tag/v0.28.1
- https://github.com/decidim/decidim/security/advisories/GHSA-529p-jj47-w3m3
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/releases/tag/v0.28.1
- https://github.com/decidim/decidim/security/advisories/GHSA-529p-jj47-w3m3
Get alerted when CVE-2024-27095 or the next vulnerability affects your stack