What’s Vulnerable › Vulnerabilities
CVE-2024-27100: Denial of service via Staff Actions in Discourse
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. In affected versions the endpoints for suspending users, silencing users and exporting CSV files weren't enforcing limits on the sizes of the parameters that they accept. This could lead to excessive resource consumption which could render an instance inoperable. A site could be disrupted by either a malicious moderator on the same site or a malicious staff member on another site in the same multisite cluster. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.2.1; before 3.3.0 — fixed in 3.2.1, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.1, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/8cade1e825e90a66f440e820992d43c6905f4b47
- https://github.com/discourse/discourse/security/advisories/GHSA-xq4v-qg27-gxgc
- https://github.com/discourse/discourse/commit/8cade1e825e90a66f440e820992d43c6905f4b47
- https://github.com/discourse/discourse/security/advisories/GHSA-xq4v-qg27-gxgc
Get alerted when CVE-2024-27100 or the next vulnerability affects your stack