What’s Vulnerable › Vulnerabilities
CVE-2024-27103: Querybook Stored Cross-Site Scripting allows Privilege Elevation
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Querybook is a Big Data Querying UI. When a user searches for their queries, datadocs, tables and lists, the search result is marked and highlighted, and this feature uses dangerouslySetInnerHTML which means that if the highlighted result has an XSS payload it will trigger. While the input to dangerouslySetInnerHTML is not sanitized for the data inside of queries which leads to an XSS vulnerability. During the "query auto-suggestion" the name of the suggested tables are set with innerHTML which leads to the XSS vulnerability. A patch to rectify this issue has been introduced in Querybook version 3.31.2.
Affected products
- pinterest querybook: before 3.31.2 — fixed in 3.31.2
How to fix
Upgrade to a fixed version: pinterest querybook 3.31.2. Check the vendor advisory for mitigations.
References
- https://github.com/pinterest/querybook/commit/449bdc9e7d679e042c3718b7ed07d2ffa3c46a8f
- https://github.com/pinterest/querybook/security/advisories/GHSA-3hjm-9277-5c88
- https://github.com/pinterest/querybook/commit/449bdc9e7d679e042c3718b7ed07d2ffa3c46a8f
- https://github.com/pinterest/querybook/security/advisories/GHSA-3hjm-9277-5c88
Get alerted when CVE-2024-27103 or the next vulnerability affects your stack