What’s Vulnerable › Vulnerabilities
CVE-2024-27104: Stored XSS in dashboards in GLPI
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. A user with rights to create and share dashboards can build a dashboard containing javascript code. Any user that will open this dashboard will be subject to an XSS attack. This issue has been patched in version 10.0.13.
Affected products
- glpi-project glpi: from 9.5.0 before 10.0.13 — fixed in 10.0.13
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/b409ca437864607b03c2014b9e3293b7f141af65
- https://github.com/glpi-project/glpi/releases/tag/10.0.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-prc3-cx5m-h5mj
- https://github.com/glpi-project/glpi/commit/b409ca437864607b03c2014b9e3293b7f141af65
- https://github.com/glpi-project/glpi/releases/tag/10.0.13
- https://github.com/glpi-project/glpi/security/advisories/GHSA-prc3-cx5m-h5mj
Get alerted when CVE-2024-27104 or the next vulnerability affects your stack