What’s Vulnerable › Vulnerabilities
CVE-2024-27123: QcalAgent
- Severity: medium (CVSS 5.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-28
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QcalAgent. The local attackers can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following version: QcalAgent 1.1.9 and later
Affected products
- QNAP Systems Inc. QcalAgent: from 1.1.0 before 1.1.9 — fixed in 1.1.9
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QcalAgent 1.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-27123 or the next vulnerability affects your stack