What’s Vulnerable › Vulnerabilities
CVE-2024-27124: QTS, QuTS hero, QuTScloud
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow users to execute commands via a network. We have already fixed the vulnerability in the following versions: QTS 5.1.3.2578 build 20231110 and later QTS 4.5.4.2627 build 20231225 and later QuTS hero h5.1.3.2578 build 20231110 and later QuTS hero h4.5.4.2626 build 20231225 and later QuTScloud c5.1.5.2651 and later
Affected products
- QNAP QTS: from 4.5.1 before 4.5.4.2627; from 5.0.0 before 5.1.3.2578; 4.5.4.2627, 5.1.3.2578 — fixed in 4.5.4.2627, 5.1.3.2578
- QNAP Systems Inc. QuTS hero: from h4.5.0 before h4.5.4.2626; from h5.0.0 before h5.1.3.2578; h4.5.4.2626, h5.1.3.2578 — fixed in h4.5.4.2626, h5.1.3.2578
- QNAP Systems Inc. QuTScloud: from c5.0.0.1919 before c5.1.5.2651 — fixed in c5.1.5.2651
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.4.2627, 5.1.3.2578; QNAP Systems Inc. QuTS hero h4.5.4.2626, h5.1.3.2578; QNAP Systems Inc. QuTScloud c5.1.5.2651. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-24-09
- https://www.qnap.com/en/security-advisory/qsa-24-09
Get alerted when CVE-2024-27124 or the next vulnerability affects your stack