What’s Vulnerable › Vulnerabilities
CVE-2024-27135: Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected products
- Apache Software Foundation Apache Pulsar: from 2.4.0 before 2.10.6; from 2.11.0 before 2.11.4; from 3.0.0 before 3.0.3; from 3.1.0 before 3.1.3; 3.2.0 — fixed in 2.10.6, 2.11.4, 3.0.3, 3.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.10.6, 2.11.4, 3.0.3, 3.1.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/12/9
- https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wn
- https://pulsar.apache.org/security/CVE-2024-27135/
- http://www.openwall.com/lists/oss-security/2024/03/12/9
- https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wn
- https://pulsar.apache.org/security/CVE-2024-27135/
Get alerted when CVE-2024-27135 or the next vulnerability affects your stack