What’s Vulnerable › Vulnerabilities
CVE-2024-27136: Apache JSPWiki: Cross-site scripting vulnerability on upload page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.2 — fixed in 2.12.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.2. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2024-27136
- https://lists.apache.org/thread/gfms8gbncqqkj52p861b8fnsypwsl1d5
- http://www.openwall.com/lists/oss-security/2024/06/23/3
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2024-27136
- https://lists.apache.org/thread/gfms8gbncqqkj52p861b8fnsypwsl1d5
Get alerted when CVE-2024-27136 or the next vulnerability affects your stack