What’s Vulnerable › Vulnerabilities
CVE-2024-27137: Apache Cassandra: unrestricted deserialization of JMX authentication credentials
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-287
Description
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorized operations. This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10. This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11. Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
Affected products
- Apache Software Foundation Apache Cassandra: from 4.0.2 before 4.0.15; from 4.1.0 before 4.1.8; from 5.0.0 (excl.) before 5.0.3; 5.0.0, 5.0.0-beta1, 5.0.0-rc1, 5.0.0-rc2 — fixed in 4.0.15, 4.1.8, 5.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 4.0.15, 4.1.8, 5.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/jsk87d9yv8r204mgqpz1qxtp5wcrpysm
- https://security.netapp.com/advisory/ntap-20250214-0004/
Get alerted when CVE-2024-27137 or the next vulnerability affects your stack