What’s Vulnerable › Vulnerabilities
CVE-2024-27181: Apache Linkis Basic management services: Privilege Escalation Attack vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-02 · updated 2026-06-17
- Weakness: CWE-269
Description
In Apache Linkis <= 1.5.0, Privilege Escalation in Basic management services where the attacking user is a trusted account allows access to Linkis's Token information. Users are advised to upgrade to version 1.6.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Linkis: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Linkis 1.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hosd73l7hxb3rpt5rb0yg0ld11zph4c6
- http://www.openwall.com/lists/oss-security/2024/08/02/3
Get alerted when CVE-2024-27181 or the next vulnerability affects your stack