What’s Vulnerable › Vulnerabilities
CVE-2024-27184: [20240801] - Core - Inadequate validation of internal URLs
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-601
Description
Inadequate validation of URLs could result into an invalid check whether an redirect URL is internal or not..
Affected products
- Joomla!: from 3.4.6 before 3.10.17; from 4.0.0 before 4.4.7; from 5.0.0 before 5.1.3 — fixed in 3.10.17, 4.4.7, 5.1.3
How to fix
Upgrade to a fixed version: Joomla! 3.10.17, 4.4.7, 5.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-27184 or the next vulnerability affects your stack