What’s Vulnerable › Vulnerabilities
CVE-2024-27189: WordPress WP Social Widget plugin <= 2.2.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in catchsquare WP Social Widget allows Stored XSS.This issue affects WP Social Widget: from n/a through 2.2.5.
Affected products
- catchsquare WP Social Widget: before 2.2.6 — fixed in 2.2.6
How to fix
Upgrade to a fixed version: catchsquare WP Social Widget 2.2.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-social-widget/wordpress-wp-social-widget-plugin-2-2-5-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-social-widget/wordpress-wp-social-widget-plugin-2-2-5-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-27189 or the next vulnerability affects your stack