What’s Vulnerable › Vulnerabilities
CVE-2024-27268: IBM WebSphere Application Server Liberty denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-770
Description
IBM WebSphere Application Server Liberty 18.0.0.2 through 24.0.0.4 is vulnerable to a denial of service, caused by sending a specially crafted request. A remote attacker could exploit this vulnerability to cause the server to consume memory resources. IBM X-Force ID: 284574.
Affected products
- IBM WebSphere Application Server: from 18.0.0.2 before 24.0.0.5 — fixed in 24.0.0.5
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 24.0.0.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/284574
- https://www.ibm.com/support/pages/node/7145809
- https://www.kb.cert.org/vuls/id/421644
- https://exchange.xforce.ibmcloud.com/vulnerabilities/284574
- https://www.ibm.com/support/pages/node/7145809
- https://www.kb.cert.org/vuls/id/421644
Get alerted when CVE-2024-27268 or the next vulnerability affects your stack