What’s Vulnerable › Vulnerabilities
CVE-2024-27270: IBM WebSphere Application Server Liberty cross-site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server Liberty 23.0.0.3 through 24.0.0.3 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in a specially crafted URI. IBM X-Force ID: 284576.
Affected products
- IBM WebSphere Application Server: from 23.0.0.3 before 24.0.0.4 — fixed in 24.0.0.4
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 24.0.0.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/284576
- https://www.ibm.com/support/pages/node/7145231
- https://exchange.xforce.ibmcloud.com/vulnerabilities/284576
- https://www.ibm.com/support/pages/node/7145231
Get alerted when CVE-2024-27270 or the next vulnerability affects your stack