What’s Vulnerable › Vulnerabilities
CVE-2024-27280
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer-overread issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. 3.0.3 is the main fixed version; however, for Ruby 3.0 users, a fixed version is stringio 3.0.1.1, and for Ruby 3.1 users, a fixed version is stringio 3.0.1.2.
Affected products
- Ruby: from 3.0.3 through 3.0.6
References
- https://hackerone.com/reports/1399856
- https://www.ruby-lang.org/en/news/2024/03/21/buffer-overread-cve-2024-27280/
- http://seclists.org/fulldisclosure/2025/Sep/53
- http://seclists.org/fulldisclosure/2025/Sep/54
- http://seclists.org/fulldisclosure/2025/Sep/55
- https://hackerone.com/reports/1399856
- https://lists.debian.org/debian-lts-announce/2024/09/msg00000.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/27LUWREIFTP3MQAW7QE4PJM4DPAQJWXF/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XYDHPHEZI7OQXTQKTDZHGZNPIJH7ZV5N/
- https://security.netapp.com/advisory/ntap-20250502-0003/
- https://www.ruby-lang.org/en/news/2024/03/21/buffer-overread-cve-2024-27280/
Get alerted when CVE-2024-27280 or the next vulnerability affects your stack