What’s Vulnerable › Vulnerabilities
CVE-2024-2729: Otter Blocks < 2.6.6 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Otter Blocks WordPress plugin before 2.6.6 does not properly escape its mainHeadings blocks' attribute before appending it to the final rendered block, allowing contributors to conduct Stored XSS attacks.
Affected products
- themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE 2.6.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5014f886-020e-49d1-96a5-2159eed8ba14/
- https://wpscan.com/vulnerability/5014f886-020e-49d1-96a5-2159eed8ba14/
Get alerted when CVE-2024-2729 or the next vulnerability affects your stack