What’s Vulnerable › Vulnerabilities
CVE-2024-27292: Docassemble unauthorized access through URL manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-706
Description
Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.
Affected products
- jhpyle docassemble: from 1.4.53 before 1.4.97 — fixed in 1.4.97
How to fix
Upgrade to a fixed version: jhpyle docassemble 1.4.97. Check the vendor advisory for mitigations.
References
- https://github.com/jhpyle/docassemble/commit/97f77dc486a26a22ba804765bfd7058aabd600c9
- https://github.com/jhpyle/docassemble/security/advisories/GHSA-jq57-3w7p-vwvv
- https://github.com/jhpyle/docassemble/commit/97f77dc486a26a22ba804765bfd7058aabd600c9
- https://github.com/jhpyle/docassemble/security/advisories/GHSA-jq57-3w7p-vwvv
Get alerted when CVE-2024-27292 or the next vulnerability affects your stack