What’s Vulnerable › Vulnerabilities
CVE-2024-27298: Parse Server literalizeRegexPart SQL Injection
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-89
Description
parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.
Affected products
- parse-community parse-server: before 6.5.0; 6.5.0-alpha1, 6.5.0-alpha2, 6.5.0-beta1, 7.0.0-alpha1, 7.0.0-alpha10, 7.0.0-alpha11 (+16) — fixed in 6.5.0
How to fix
Upgrade to a fixed version: parse-community parse-server 6.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/a6e654943536932904a69b51e513507fcf90a504
- https://github.com/parse-community/parse-server/commit/cbefe770a7260b54748a058b8a7389937dc35833
- https://github.com/parse-community/parse-server/releases/tag/6.5.0
- https://github.com/parse-community/parse-server/releases/tag/7.0.0-alpha.20
- https://github.com/parse-community/parse-server/security/advisories/GHSA-6927-3vr9-fxf2
- https://github.com/parse-community/parse-server/commit/a6e654943536932904a69b51e513507fcf90a504
- https://github.com/parse-community/parse-server/commit/cbefe770a7260b54748a058b8a7389937dc35833
- https://github.com/parse-community/parse-server/releases/tag/6.5.0
- https://github.com/parse-community/parse-server/releases/tag/7.0.0-alpha.20
- https://github.com/parse-community/parse-server/security/advisories/GHSA-6927-3vr9-fxf2
Get alerted when CVE-2024-27298 or the next vulnerability affects your stack