What’s Vulnerable › Vulnerabilities

CVE-2024-27354: phpseclib: guardrails needed on isPrime and randomPrime

Description

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

Affected products

How to fix

Upgrade to a fixed version: phpseclib 1.0.23, 2.0.47, 3.0.36; Packagist Phpseclib/Phpseclib 1.0.23, 2.0.47, 3.0.36. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-27354 or the next vulnerability affects your stack