What’s Vulnerable › Vulnerabilities
CVE-2024-27355: phpseclib guardrails needed on OID length
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).
Affected products
- Debian Linux: 10.0
- phpseclib: from 1.0.0 before 1.0.23; from 2.0.0 before 2.0.47; from 3.0.0 before 3.0.36 — fixed in 1.0.23, 2.0.47, 3.0.36
- Packagist Phpseclib/Phpseclib: from 2.0.0 before 2.0.47; from 3.0.0 before 3.0.36; from 0.1.1 before 1.0.23; 2.0.0, 2.0.1, 2.0.10, 2.0.11, 2.0.12, 2.0.13 (+99) — fixed in 2.0.47, 3.0.36, 1.0.23
How to fix
Upgrade to a fixed version: phpseclib 1.0.23, 2.0.47, 3.0.36; Packagist Phpseclib/Phpseclib 2.0.47, 3.0.36, 1.0.23. Check the vendor advisory for mitigations.
References
- https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b
- https://github.com/phpseclib/phpseclib/blob/978d081fe50ff92879c50ff143c62a143edb0117/phpseclib/File/ASN1.php#L1129
- https://lists.debian.org/debian-lts-announce/2024/03/msg00002.html
- https://lists.debian.org/debian-lts-announce/2024/03/msg00003.html
- https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b
- https://github.com/phpseclib/phpseclib/blob/978d081fe50ff92879c50ff143c62a143edb0117/phpseclib/File/ASN1.php#L1129
- https://lists.debian.org/debian-lts-announce/2024/03/msg00002.html
- https://lists.debian.org/debian-lts-announce/2024/03/msg00003.html
Get alerted when CVE-2024-27355 or the next vulnerability affects your stack