What’s Vulnerable › Vulnerabilities
CVE-2024-2738: Permalink Manager Lite and Permalink Manager Pro <= 2.4.3.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Permalink Manager Lite and Pro plugins for WordPress are vulnerable to Reflected Cross-Site Scripting via the ‘s’ parameter in multiple instances in all versions up to, and including, 2.4.3.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- mbis Permalink Manager Lite: before 2.4.3.2 — fixed in 2.4.3.2
How to fix
Upgrade to a fixed version: mbis Permalink Manager Lite 2.4.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/561ac3c17b92cb55d3032504a076fa4b
- https://gist.github.com/Xib3rR4dAr/b1eec00e844932c6f2f30a63024b404e
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3052848%40permalink-manager%2Ftrunk&old=3034660%40permalink-manager%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7020d5a1-a4a6-489c-8615-bc7898553bcf?source=cve
- https://gist.github.com/Xib3rR4dAr/561ac3c17b92cb55d3032504a076fa4b
- https://gist.github.com/Xib3rR4dAr/b1eec00e844932c6f2f30a63024b404e
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3052848%40permalink-manager%2Ftrunk&old=3034660%40permalink-manager%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7020d5a1-a4a6-489c-8615-bc7898553bcf?source=cve
Get alerted when CVE-2024-2738 or the next vulnerability affects your stack