What’s Vulnerable › Vulnerabilities
CVE-2024-27389: pstore: inode: Only d_invalidate() is needed
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-08-04
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: pstore: inode: Only d_invalidate() is needed Unloading a modular pstore backend with records in pstorefs would trigger the dput() double-drop warning: WARNING: CPU: 0 PID: 2569 at fs/dcache.c:762 dput.part.0+0x3f3/0x410 Using the combo of d_drop()/dput() (as mentioned in Documentation/filesystems/vfs.rst) isn't the right approach here, and leads to the reference counting problem seen above. Use d_invalidate() and update the code to not bother checking for error codes that can never happen. ---
Affected products
- Linux kernel: from 5.8 before 6.1.83; from 6.2 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 6.1.83, 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 6.1.83, 6.6.23, 6.7.11, 6.8.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/340682ed1932b8e3bd0bfc6c31a0c6354eb57cc6
- https://git.kernel.org/stable/c/4cdf9006fc095af71da80e9b5f48a32e991b9ed3
- https://git.kernel.org/stable/c/a43e0fc5e9134a46515de2f2f8d4100b74e50de3
- https://git.kernel.org/stable/c/cb9e802e49c24eeb3af35e9e8c04d526f35f112a
- https://git.kernel.org/stable/c/d0ee2a8adb6673382cce8a4280e1ca0849b3b783
- https://git.kernel.org/stable/c/db6e5e16f1ee9e3b01d2f71c7f0ba945f4bf0f4e
- https://git.kernel.org/stable/c/340682ed1932b8e3bd0bfc6c31a0c6354eb57cc6
- https://git.kernel.org/stable/c/4cdf9006fc095af71da80e9b5f48a32e991b9ed3
- https://git.kernel.org/stable/c/a43e0fc5e9134a46515de2f2f8d4100b74e50de3
- https://git.kernel.org/stable/c/cb9e802e49c24eeb3af35e9e8c04d526f35f112a
- https://git.kernel.org/stable/c/db6e5e16f1ee9e3b01d2f71c7f0ba945f4bf0f4e
Get alerted when CVE-2024-27389 or the next vulnerability affects your stack