What’s Vulnerable › Vulnerabilities
CVE-2024-27390: ipv6: mcast: remove one synchronize_net() barrier in ipv6_mc_down()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-07-24
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: mcast: remove one synchronize_net() barrier in ipv6_mc_down() As discussed in the past (commit 2d3916f31891 ("ipv6: fix skb drops in igmp6_event_query() and igmp6_event_report()")) I think the synchronize_net() call in ipv6_mc_down() is not needed. Under load, synchronize_net() can last between 200 usec and 5 ms. KASAN seems to agree as well.
Affected products
- Linux kernel: from 5.13 before 5.15.153; from 5.16 before 6.1.83; from 6.2 before 6.6.23; from 6.7 before 6.7.11; from 6.8 before 6.8.2 — fixed in 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.153, 6.1.83, 6.6.23, 6.7.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/17ef8efc00b34918b966388b2af0993811895a8c
- https://git.kernel.org/stable/c/26d4bac55750d535f1f0b8790dc26daf6089e373
- https://git.kernel.org/stable/c/5da9a218340a2bc804dc4327e5804392e24a0b88
- https://git.kernel.org/stable/c/7eb06ee5921189812e6b4bfe7b0f1e878be16df7
- https://git.kernel.org/stable/c/9d159d6637ccce25f879d662a480541ef4ba3a50
- https://git.kernel.org/stable/c/a03ede2282ebbd181bd6f5c38cbfcb5765afcd04
- https://git.kernel.org/stable/c/bfd2f3c58ad86ad33db80515e6c3503e0414e44b
- https://git.kernel.org/stable/c/17ef8efc00b34918b966388b2af0993811895a8c
- https://git.kernel.org/stable/c/26d4bac55750d535f1f0b8790dc26daf6089e373
- https://git.kernel.org/stable/c/5da9a218340a2bc804dc4327e5804392e24a0b88
- https://git.kernel.org/stable/c/7eb06ee5921189812e6b4bfe7b0f1e878be16df7
- https://git.kernel.org/stable/c/9d159d6637ccce25f879d662a480541ef4ba3a50
Get alerted when CVE-2024-27390 or the next vulnerability affects your stack