What’s Vulnerable › Vulnerabilities
CVE-2024-27396: net: gtp: Fix Use-After-Free in gtp_dellink
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-10-15
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net: gtp: Fix Use-After-Free in gtp_dellink Since call_rcu, which is called in the hlist_for_each_entry_rcu traversal of gtp_dellink, is not part of the RCU read critical section, it is possible that the RCU grace period will pass during the traversal and the key will be free. To prevent this, it should be changed to hlist_for_each_entry_safe.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.14.162 before 4.15; from 4.19.93 before 4.19.313; from 5.4.8 before 5.4.275; from 5.5 before 5.10.216; from 5.11 before 5.15.158; from 5.16 before 6.1.90 — fixed in 4.15, 4.19.313, 5.10.216, 5.15.158, 5.4.275, 6.1.90
How to fix
Upgrade to a fixed version: Linux kernel 4.15, 4.19.313, 5.10.216, 5.15.158. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/07b20d0a3dc13fb1adff10b60021a4924498da58
- https://git.kernel.org/stable/c/0caff3e6390f840666b8dc1ecebf985c2ef3f1dd
- https://git.kernel.org/stable/c/25a1c2d4b1fcf938356a9688a96a6456abd44b29
- https://git.kernel.org/stable/c/2aacd4de45477582993f8a8abb9505a06426bfb6
- https://git.kernel.org/stable/c/2e74b3fd6bf542349758f283676dff3660327c07
- https://git.kernel.org/stable/c/718df1bc226c383dd803397d7f5d95557eb81ac7
- https://git.kernel.org/stable/c/cd957d1716ec979d8f5bf38fc659aeb9fdaa2474
- https://git.kernel.org/stable/c/f2a904107ee2b647bb7794a1a82b67740d7c8a64
- https://git.kernel.org/stable/c/07b20d0a3dc13fb1adff10b60021a4924498da58
- https://git.kernel.org/stable/c/0caff3e6390f840666b8dc1ecebf985c2ef3f1dd
- https://git.kernel.org/stable/c/25a1c2d4b1fcf938356a9688a96a6456abd44b29
- https://git.kernel.org/stable/c/2aacd4de45477582993f8a8abb9505a06426bfb6
Get alerted when CVE-2024-27396 or the next vulnerability affects your stack