What’s Vulnerable › Vulnerabilities
CVE-2024-27416: Bluetooth: hci_event: Fix handling of HCI_EV_IO_CAPA_REQUEST
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: hci_event: Fix handling of HCI_EV_IO_CAPA_REQUEST If we received HCI_EV_IO_CAPA_REQUEST while HCI_OP_READ_REMOTE_EXT_FEATURES is yet to be responded assume the remote does support SSP since otherwise this event shouldn't be generated.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.14.328 before 4.15; from 4.19.297 before 4.19.309; from 5.4.259 before 5.4.271; from 5.10.199 before 5.10.212; from 5.15.137 before 5.15.151; from 6.1.60 before 6.1.81 — fixed in 4.15, 4.19.309, 5.10.212, 5.15.151, 5.4.271, 6.1.81
How to fix
Upgrade to a fixed version: Linux kernel 4.15, 4.19.309, 5.10.212, 5.15.151. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/30a5e812f78e3d1cced90e1ed750bf027599205f
- https://git.kernel.org/stable/c/79820a7e1e057120c49be07cbe10643d0706b259
- https://git.kernel.org/stable/c/7e74aa53a68bf60f6019bd5d9a9a1406ec4d4865
- https://git.kernel.org/stable/c/8e2758cc25891d2b76717aaf89b40ed215de188c
- https://git.kernel.org/stable/c/afec8f772296dd8e5a2a6f83bbf99db1b9ca877f
- https://git.kernel.org/stable/c/c3df637266df29edee85e94cab5fd7041e5753ba
- https://git.kernel.org/stable/c/df193568d61234c81de7ed4d540c01975de60277
- https://git.kernel.org/stable/c/fba268ac36ab19f9763ff90d276cde0ce6cd5f31
- https://git.kernel.org/stable/c/30a5e812f78e3d1cced90e1ed750bf027599205f
- https://git.kernel.org/stable/c/79820a7e1e057120c49be07cbe10643d0706b259
- https://git.kernel.org/stable/c/7e74aa53a68bf60f6019bd5d9a9a1406ec4d4865
- https://git.kernel.org/stable/c/8e2758cc25891d2b76717aaf89b40ed215de188c
Get alerted when CVE-2024-27416 or the next vulnerability affects your stack